What browsers are compatible with EventGeek?

EventGeek supports all modern web browsers, including Chrome, Firefox, Safari and Internet Explorer version 11 and higher. EventGeek is not accessible on IE 10 or lower.

If you're not able to access EventGeek, it may be because you're on an outdated version of your browser. Please make sure your browser is updated before trying to reload the platform.

Was this article helpful?